Как я делал блог из WordPress (часть 1) или Нахрена оно вообще надо?

Читать — полезное занятие. С этим никто спорить не станет, вот и читаю я последнее время блоги таких людей как Сергей Жуковcкий, Давыдов. Увлекательно, а главное живо и полезно пишут. И что интересно, особо живо читаются отчёты о прибылях с партнёрок и сторонних проектов. Ну что тут скажешь, тоже загорелся «финансовой независимостью» (как много в этой фразе и как часто её в последнее время употребляют везде и всюду) и, впитав некоторый объём информации, по-новому взглянул на свой недоблог — сложилось не самое хорошее впечатление — да, красивенько, но не функционально и большинство советов более опытных блоггеров, как то — добавлять после каждого поста кнопки подписки на RSS, теги, ссылки на соц.закладки, у меня не выполняются.

Стал копать глубже — воспользовался Гугловым «Инструментом для веб-мастеров», который выявил странный глюк в движке WordPress (2.0.5) — ссылки на категории, в которых содержались заглавные буквы (например, AJAX), выдавали 404 ошибку. Долго думать и сомневаться не стал, т.к. давно уже положил глаз на новый релиз WordPress под номером 2.1.1, переведенный к тому времени Максимом. Скачал архив и…

…И понеслось. Делал всё по шагам, чтобы «уж точно», но естественно не прошло без эксцессов.
До этого у меня стоял WordPress с Windows-1251 кодировкой, а в новой 2.1.x ветке, из-за наличия множества AJAX-вставок, все переведено в UTF-8 (если кто не в курсе, то все данные в AJAX передаются именно в этой кодировке). Максим провёл огромную работу, чтобы облегчить переход от win-версии к utf-8 и отдельно описал это в readme, прилагаемом к архиву. Выполнив всю необходимую последовательность действий и стартанув сайт, узрел крякозябры. Посмотрел в FireBug в meta и оказалось, что кодировка в header так и отдаётся Windows-1251, а вот контент уже в UTF. Пришлось лезть в БД и в таблице wp_options в столбце option_name искать строку с ‘blog_charset’ , в которой как раз и стояла старая кодировка.
После изменения всё якобы стало хорошо, во всяком случае текст стал читаемым. Полез в админскую панель, ввёл логин и пароль и… «Вы не имеете достаточно прав для доступа к данной странице». Снова — читать форум, читать readme — «Если и после этого WordPress выдает сообщени об ошибке, то откройте файл wp-config.php и в самом конце файла уберите комментарий («//») со строчки: require_once(ABSPATH . ‘wp-upgrade-all.php’);maxsite_wp_upgrade();». Не повторяйте моей ошибки и не забудьте её (строчку) потом закомментровать.

Дальше-больше, естественно старая тема Vistered Little 1.6 (локализация), отказалась работать с новым движком (это меня не слишком расстроило, т.к. всё равно думал его сменить на нечто менее броское), но вот то, что Advanced TinyMCE Editor перестал корректно работать с FireFox, выдавая вместо окна для редактирования ссылок пустую область, меня убило.

О том, как я боролся с этой проблемой, настройке разных плагинов для WordPress, а так же о идеях — читайте в следующих выпусках.


Остальные части из серии «Как я делал блог из WordPress»:Часть 2 — «DownloadCounter и WP-stats по-русски»

Как я делал блог из WordPress (часть 1) или Нахрена оно вообще надо?: 5 комментариев

Добавить комментарий